Un utilisateur a demand√© ūüĎá

Salut,

J’utilise un calendrier d’√©v√©nements sur un serveur PHP 7, mais j’ai le message suivant dans le tableau de bord WP¬†:

Calendrier des √©v√©nements n√©cessite PHP 5.6 ou sup√©rieur. Pour permettre un meilleur contr√īle des dates, des am√©liorations de haute s√©curit√© et des gains de performances. Contactez votre administrateur syst√®me ou h√©bergeur et demandez une mise √† niveau vers la derni√®re version de PHP.

J’ai v√©rifi√© la version PHP et je suis √† 7.0. Je peux utiliser 7.1 .2 ou .3.

De plus, puisque ce message refuse de charger le calendrier des √©v√©nements. Le calendrier des √©v√©nements est actif dans les extensions WordPress mais je ne peux pas y acc√©der. J’ai juste un message √† propos de PHP.

Que se passe-t-il ? Merci


(@ barryhughes-1)

il y a 1 an, 9 mois

Wow, d√©sol√© d’entendre √ßa @drwily.

Je comprends parfaitement que vous ayez d√©j√† arr√™t√© et v√©rifi√© votre version de PHP, mais notez que vous me dites comment vous avez confirm√© cela, √©tait-ce via le panneau de configuration d’un serveur Web, par exemple¬†?

Avez-vous un lien vers votre site que vous pouvez partager ?


(@mosley)

il y a 1 an, 9 mois

Cela m’arrive aussi. J’ai v√©rifi√© que j’ex√©cute PHP version 7.0.33 √† partir de mon panneau de contr√īle h√īte.

Je ne vois aucune mention du calendrier des √©v√©nements sur ma page d’administration WordPress autre que le message indiquant que PHP n√©cessite Calendar 5.6 ou sup√©rieur.


(@ barryhughes-1)

il y a 1 an, 9 mois

D’accord, nous appr√©cions votre patience pendant que nous examinons cela et vous remercions d’avoir pris le temps de fournir ces rapports.

Vous pouvez télécharger la version 4.7.4 ici (qui ne nécessite pas PHP 5.6) et elle devrait fournir un moyen de résoudre ce problème en attendant.

Si vous √™tes capable et d√©sireux de le faire, et si vous pouvez visiter le √Čv√©nements ‚Üí Aide l’√©cran d’administration, vous trouverez un √©l√©ment sur cette page appel√© “Informations syst√®me”. √Ä l’int√©rieur, nous listons la version PHP. Ce serait formidable si vous pouviez partager ce que vous y voyez et cela nous permettra peut-√™tre de mieux comprendre ce qui ne va pas.

Merci encore!


(@drwily)

il y a 1 an, 9 mois

Merci pour votre aide ūüėČ

Pourriez-vous me dire comment vous avez confirm√© cela¬†? √Čtait-ce via le panneau de contr√īle d’un fournisseur d’h√©bergement Web, par exemple¬†?

J’ai param√©tr√© la version moi-m√™me dans le panneau de configuration de mon h√©bergeur.

Si vous pouvez et voulez le faire, et si vous pouvez visiter l’√©cran d’administration des √©v√©nements ‚Üí Aide

Avec la derni√®re version, il n’y a pas de section d’√©v√©nements dans le tableau de bord WordPress.


(@ barryhughes-1)

il y a 1 an, 9 mois

Hmm, pour clarifier en cas de confusion¬†: vous avez r√©ussi √† revenir en arri√®re et √† activer le calendrier des √©v√©nements 4.7.4, mais vous ne voyez pas le menu des √©v√©nements dans le panneau/l’environnement d’administration¬†?

Si oui, utilisez-vous l’un de nos autres plugins en m√™me temps¬†?


(@drwily)

il y a 1 an, 9 mois

donc, pour √©claircir en cas de confusion: vous avez r√©ussi √† revenir au calendrier des √©v√©nements 4.7.4 et √† l’activer

Je n’essaie pas cela avec la derni√®re version. Avec 4.7.4 √ßa marche. Voici les informations syst√®me¬†:

Home URL
    https://www.asso-sc.com
Site URL
    https://www.asso-sc.com
Site Language
    fr_FR
Character Set
    UTF-8

Install keys
    -
WordPress version
    5.0.3
Permalink Structure
    https://www.asso-sc.com/%postname%/
PHP version
    5.4.45
PHP

        max_execution_time = 300
        memory_limit = 512M
        upload_max_filesize = 128M
        post_max_size = 130M
        display_errors = 0
        log_errors =

Server
    Apache
SAPI
    fpm-fcgi
Plugins

        Akismet Anti-Spam version 4.1.1 by Automattic(https://automattic.com/wordpress-plugins/)
        Change WP Mail From Details version 1.0 by Ruhul Amin(http://www.tipsandtricks-hq.com)
        Convert Post Types version 1.4 by Stephanie Leary(http://stephanieleary.com)
        Facebook Page Plugin (Likebox) version 1.7 by Smakify(http://smakify.com)
        Fancy Gallery Lite version 1.5.37 by Dennis Hoppe(http://DennisHoppe.de)
        Flexo Archives Hack MOD version 2.1.5 b0.1 by Heath Harrelson
        Image Widget version 4.4.7 by Modern Tribe, Inc.(http://m.tri.be/iwpdoc)
        Juiz Social Post Sharer version 1.4.9 by Geoffrey Crofte(http://geoffrey.crofte.fr)
        Fast Secure Contact Form version 4.0.56 by fastsecure(http://www.642weather.com/weather/scripts.php)
        Social version 3.1.1 by Crowd Favorite(http://crowdfavorite.com/)
        Stop Spammers version 7.1 by Bryan Hadaway(https://calmestghost.com/)
        The Events Calendar version 4.7.4 by Modern Tribe, Inc.(http://m.tri.be/1x)
        Update Notifications Manager version 1.1.2 by GeekPress(http://www.geekpress.fr/)
        Widget_custom version 1.0 by DtrAA(http://david.desaunais.fr)
        Wordfence Security version 7.2.2 by Wordfence(http://www.wordfence.com/)
        WP-Filebase version 0.2.9.35 by Fabian Schlieper(http://wpfilebase.com/)
        WP User Avatar version 2.1.6 by flippercode(http://www.flippercode.com/)
        WS Facebook Like Box Widget version 4.1 by WebShouters(http://www.webshouters.com/)

Network Plugins
    -
MU Plugins
    -
Theme
    Simm's Club
Multisite
    -
Settings

        tribeEventsTemplate = page-calendar.php
        tribeEventsBeforeHTML =
        tribeEventsAfterHTML =
        previous_ecp_versions =

        Array
        (
            [0] => 0
            [1] => 2.0.11
            [2] => 3.12.3
            [3] => 4.0.7
            [4] => 4.1.2
            [5] => 4.4.2
            [6] => 4.6.8
            [7] => 4.6.25
        )

        latest_ecp_version = 4.7.4
        welcome_notice = 1
        displayedPressTrendsDialogue = 1
        donate-link =
        viewOption = month
        eventsSlug = events
        singleEventSlug = event
        postsPerPage = 3
        showComments =
        multiDayCutoff = 12:00
        embedGoogleMaps = 1
        embedGoogleMapsHeight = 350
        embedGoogleMapsWidth = 100%
        embedGoogleMapsZoom = 10
        sendPressTrendsData =
        debugEvents =
        tribeEnableViews =

        Array
        (
            [0] => list
            [1] => month
            [2] => day
        )

        schema-version = 4.7.4
        recurring_events_are_hidden = hidden
        earliest_date = 2013-04-18 08:00:00
        latest_date = 2019-01-12 08:00:00
        earliest_date_markers =

        Array
        (
            [0] => 380
        )

        latest_date_markers =

        Array
        (
            [0] => 1682
        )

        last-update-message-the-events-calendar = 4.7.4

WP Timezone
    Europe/Paris
WP GMT Offset
    1
Default PHP Timezone
    UTC
WP Date Format
    j F Y
WP Time Format
    G h i min
Week Starts On
    1
Common Library Dir
    /home/assosc/www/wp-content/plugins/the-events-calendar/common/src/Tribe
Common Library Version
    4.8.5 


(@vetilmi)

il y a 1 an, 9 mois

Cela m’arrive aussi : j’ai migr√© de PHP 5.4.45 vers PHP 7.3 chez OVH et je ne vois aucun commentaire dans le calendrier des √©v√©nements sur ma page d’administration WordPress, √† part le message qui n√©cessite PHP 5.6 ou sup√©rieur dans les √©v√©nements Calendrier.


(@ziadn)

il y a 1 an, 9 mois

J’ai le m√™me probl√®me. J’ai essay√© d’installer 4.7.4, mais il me dit que le dossier du plugin existe d√©j√† (“Le dossier de destination existe d√©j√†”). Et j’h√©site √† supprimer le plugin en premier car WP me dit qu’il supprimera les donn√©es. Veuillez aviser,

Ziad

Cette réponse a été modifiée il y a 1 an et 9 mois par. Cette réponse a été modifiée il y a 1 an et 9 mois par.


(@deuveudeu)

il y a 1 an, 9 mois

J’ai eu le m√™me probl√®me lors de la mise √† niveau vers wordpress 5.0.3, puis des calendriers d’√©v√©nements vers 4.8.1. Je v√©rifie la version de PHP chez Hosteur (mon h√©bergeur en France), la version 5.6.38 que j’ai r√©install√© est la 4.7.4 (merci √† Barry pour les conseils)

Ziadn, je n’ai pas supprim√© la version 4.8.1. Dites simplement un autre nom via FTP/plugins (je viens de mettre une hache √† la fin…)

Une fois l’ancienne version install√©e, vous verrez 2 calendriers d’√©v√©nements, activez l’ancien et r√©cup√©rez tous mes √©v√©nements.

j’esp√®re que √ßa aide


(@drwily)

il y a 1 an, 9 mois

Des news pour cette erreur ?


(@ barryhughes-1)

il y a 1 an, 9 mois

Désolé pour le retard, @drwily.

Lisez-moi ceci (à partir de vos informations système):

PHP version
    5.4.45

Cependant, je sais que vous l’avez d√©j√† remarqu√© auparavant, “J’utilise un calendrier d’√©v√©nements sur un serveur PHP 7”. Il semble donc y avoir une sorte de divergence. Une autre chose qui ressort est que vous utilisez Apache¬†:

Server
    Apache

Bien que la m√™me chose puisse √™tre possible avec d’autres serveurs Web, la configuration possible suivante √©tait ce dont l’√©quipe discutait avec Apache¬†:

dans apache, l’utilisateur peut avoir une version de PHP par dossier

Autrement dit, votre compte d’h√©bergement peut avoir PHP 7.x par d√©faut, mais les choses peuvent √™tre configur√©es de telle sorte que PHP 5.4 (dans ce cas) soit utilis√© pour le r√©pertoire dans lequel r√©side votre installation WordPress.

Cela expliquerait ce que nous voyons dans vos informations syst√®me. Pouvez-vous jeter un coup d’Ňďil √† votre arrangement d’h√©bergement et/ou vous renseigner aupr√®s de votre h√īte d√®s maintenant¬†?

Voici quelques conseils pertinents d’un blog tiers¬†: Si vous utilisez un compte d’h√©bergement partag√©, vous ne pourrez peut-√™tre pas suivre les √©tapes recommand√©es, mais vous pouvez le partager avec l’√©quipe d’assistance de votre h√©bergeur.

Cela nous rapproche-t-il d’une solution ?


(@drwily)

il y a 1 an, 9 mois

OK merci. Je vais contacter mon h√©bergeur pour savoir d’o√Ļ vient le probl√®me.


(@ziadn)

il y a 1 an, 9 mois

deuveudeu, merci, ça marche,

Ziad


(@drwily)

il y a 1 an, 9 mois

Merci Barry, votre solution fonctionne. En fait, il y a ma configuration d’h√īte qui force l’utilisation de PHP 5.4.

Dans mon panneau d’accueil, la configuration est d√©finie sur PHP 7.3. Mais, dans le stockage h√īte, il existe un fichier de configuration qui impl√©mente la version PHP.

Mon hébergeur est OVH et la configuration doit être ainsi :

‚Äď Fichier .OVHCONFIG √† la racine du repository (supprimez tous les .OVHCONFIG du sous-dossier ou si ces fichiers ne reprennent pas celui de la racine sauf si vous souhaitez utiliser d’autres versions de PHP). Ajoutez ou modifiez la ligne suivante¬†:

app.engine.version=7.3

‚Äď Fichier .htaccess √† la racine + dans le dossier d’installation de wordpress. Ajoutez ou modifiez la ligne suivante¬†:

SetEnv PHP_VER 7_3

Maintenant, la derni√®re version de Event Calendar fonctionne parfaitement et l’avertissement concernant l’ancienne version de PHP a disparu.

Merci pour l’aide.


(@erishel)

il y a 1 an, 8 mois

Agréable!

Puisque vous avez résolu ce problème, je vais marquer ce sujet comme une solution.

N’h√©sitez pas √† nous contacter si vous avez √† nouveau besoin d’aide¬†!

Prends soin de toi Ed ūü§ü

Cela a-t-il résolu votre problème ?

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *