Un utilisateur a demandé 👇

Le plugin de compatibilité suggère qu’il existe 2 problèmes connus qui rendent la version actuelle (v509) non compatible avec php7. Existe-t-il des plans pour résoudre ces problèmes ?

FONDATION 1 ERREUR ET 1 AVERTISSEMENT LIÉS À 2 RÉSEAUX ——————————————————————————————— 849 | BOGUE | L’extension ‘mysql_’ n’est plus signalée depuis PHP 5.5 et a été supprimée de PHP 7.0 ; Utilisez mysqli à la place AVERTISSEMENT L’obsolescence du constructeur de classe de style PHP4 n’est pas prise en charge dans PHP 7. ———————————————————————————— —————— —————

FICHIER : /public_html/wp-content/plugins/cp-contact-form-with-paypal/captcha/captcha.php ———————————————————————— — —————————————— 1 ERREUR AFFECTANT 1 LIGNE ———————————————————————————— — ————— ———————— 16 | BOGUE | La fonction session_register() n’est plus signalée depuis PHP 5.3 et a été supprimée de PHP 5.4 ; Utilisez $_SESSION à la place —————————————————————————————————————————


(@codepeople)

il y a 2 ans, 8 mois

Salut,

Ce code provient d’une très ancienne version du plugin. Assurez-vous de mettre à jour la dernière version pour obtenir le code mis à jour.

Si vous utilisez une version commerciale du plugin et avez besoin d’aide pour la mise à niveau, veuillez poster un ticket sur https://cfpaypal.dwbooster.com/contact-us

Merci.


(@freshideawebsites)

il y a 2 ans, 8 mois

Merci. La page du plugin WP n’indiquait pas qu’une mise à jour était disponible, mais vous aviez raison… il existe une version plus récente (et oui, c’est la version PRO). J’ai téléchargé la v5.2.36 à partir du lien fourni (et je suppose qu’il s’agit de la dernière version). Malheureusement, l’analyse de compatibilité 2 affiche toujours une erreur. L’un est différent du premier scan (ligne 971 dans cp_contactformpp.php), mais le second est identique aux résultats du premier scan (ligne 16 dans captcha.php).

FICHIER : /home/demo/generic.freshideademo.com/wp-content/plugins/cp-contact-form-with-paypal/cp_contactformpp.php —————————————————— —— ——————————————————— 1 ERREUR AFFECTANT 1 LIGNE —————————————————————— — ——————— ———————— 971 | BOGUE | L’extension ‘mysql_’ n’est plus signalée depuis PHP 5.5 et a été supprimée de PHP 7.0 ; Utilisez plutôt mysqli ————————————————————————————————————————

FICHIER : /home/demo/generic.freshideademo.com/wp-content/plugins/cp-contact-form-with-paypal/captcha/captcha.php ———————————————— —— ——————————————————————— 1 ERREUR AFFECTANT 1 LIGNE —————————————————— — ———— —————————————————————— 16 | BOGUE | La fonction session_register() n’est plus signalée depuis PHP 5.3 et a été supprimée de PHP 5.4 ; Utilisez $_SESSION à la place —————————————————————————————————————————


(@codepeople)

il y a 2 ans, 8 mois

Salut,

La dernière version de la version professionnelle (la version que vous utilisez) est la #5.2.38

Utilisez à nouveau votre lien de téléchargement personnel et assurez-vous que le numéro de version affiché dans la zone des plugins est 5.2.38.

Instructions d’installation/mise à jour :

http://wordpress.dwbooster.com/faq/general-questions#q94

Merci.


(@freshideawebsites)

il y a 2 ans, 8 mois

Génial. Merci pour votre réponse rapide. La V5.2.38 (24 février) passe désormais avec succès les tests de compatibilité PHP7. Encore une fois, quel service rapide!

Cela a-t-il résolu votre problème ?

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *