Un utilisateur a demand√© ūüĎá

Salut, j’ai un site qui supprime ces erreurs de leur plugin. Cela a commenc√© √† se produire juste apr√®s que j’ai d√©plac√© mon site d’un ancien h√©bergeur vers un nouveau.

Avertissement¬†: fopen (/path/to/old/server/wp-content/plugins/photography-portfolio/photography-portfolio.php)¬†: Impossible d’ouvrir le flux¬†: aucun fichier ou r√©pertoire de ce type dans /path/to/new /server/ wp-include/functions.php √† la ligne 4834

Attention : fread() s’attend √† ce que le param√®tre 1 soit une ressource, bool√©en donn√© dans /path/to/new/server/wp-includes/functions.php en ligne 4837

Attention¬†: fclose() s’attend √† ce que le param√®tre¬†1 soit une ressource, un bool√©en donn√© dans /path/to/new/server/wp-includes/functions.php en ligne 4840

J’ai regard√© autour de moi dans le code mais je n’ai rien trouv√© sur l’endroit o√Ļ le chemin ci-dessus est stock√©. La base de donn√©es et son plugin semblent utiliser les constantes __FILE__ et ainsi de suite. Existe-t-il un moyen de me conseiller sur l’endroit o√Ļ rechercher ce que ces fonctions appellent?


(@justnorris)

il y a 2 ans, 8 mois

Le plugin n’est pas responsable de ce type de comportement. Il me semble que le serveur fait quelque chose pour produire ces erreurs. Peut-√™tre des plugins de mise en cache ? Vous avez besoin de votre fournisseur d’h√©bergement pour diagnostiquer ce qui se passe ici.

Tout ce que je peux vous dire avec certitude, c’est que le plugin ne stocke aucune trace nulle part, il est aussi portable qu’un plugin WordPress. Il faut chercher le probl√®me ailleurs.


(@eithne52)

il y a 2 ans, 4 mois

Ce qui a fonctionn√© pour moi √©tait a) changer le th√®me du site Web b) d√©sactiver et r√©activer le plugin ca c) puis revenir au th√®me que j’utilisais.

Cela a fonctionn√©, mais si vous changez d’abord le th√®me (avec au moins un portefeuille minimal), sinon, vous vous retrouverez avec un √©cran d’erreur et vous devrez ensuite activer le plugin √† partir de la base de donn√©es.

quelque part avec les plugins, c’est d√©finitivement un probl√®me de cache, j’esp√®re que cela aidera


(@asaliga)

il y a 2 ans, 4 mois

J’ai la m√™me question. Malheureusement, les √©tapes ci-dessus n’ont pas r√©solu le probl√®me. J’ai vid√© le cache du navigateur et d√©sinstall√© tous les plugins de mise en cache.

Le problème est survenu lors de la migration de Bluehost vers Hostgator.


(@justnorris)

il y a 2 ans, 3 mois

Salut @asaliga – Apr√®s avoir d√©sinstall√© les plugins de mise en cache, ils laissent souvent des traces de fichiers de mise en cache encore utilis√©s, supprimer le plugin de mise en cache n’est pas si simple. Regarde toi /var/www/site.com/wp-content r√©pertoire et voyez si quelque chose li√© √† la mise en cache est toujours l√†.

De plus, √† mon avis, Hostgator et GoDaddy sont parmi les pires fournisseurs d’h√©bergement (de tous les plus populaires). Je ne dis pas que le probl√®me est sp√©cifique √† Hostgator, mais je ne serais pas surpris si c’√©tait le cas.


(@nicolasnadel)

il y a 1 an, 9 mois

Ma fin lance √©galement les m√™mes erreurs … J’ai recherch√© une mise en cache suspecte mais pas de chance jusqu’√† pr√©sent. FWIW Je suis sur Digital Ocean, mais Linode lance la m√™me erreur.

C’est bizarre parce que fopen fait r√©f√©rence √† mon chemin de d√©veloppement local : /Applications/MAMP/htdocs/site/wp-content/plugins/photography-portfolio/photography-portfolio.php

Je ne trouve aucune r√©f√©rence √† ce chemin dans la base de donn√©es ou dans l’ensemble du projet. Je mettrai √† jour si je trouve un flux de travail

Cette réponse a été modifiée il y a 1 an et 9 mois.


(@donencia)

il y a 1 an, 9 mois

Merci, nous attendons la solution exacte.


(@ sebek819)

il y a 1 an, 8 mois

désactivez tous les plugins et activez-le = OK ! Cela a fonctionné pour moi!

Cela a-t-il résolu votre problème ?

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *